Tips & Video Tutoriales, Wifislax, VMware, GNS3, VirtualBox, CCNA, Cisco Routers & Switches, [ Programming ]

Configuración de OSPF en un Cisco 3725 (IOS) y Nexus 7000 (NX-OS)

A continuación, se muestra un ejemplo de configuración básica de OSPF entre un Switch Nexus y un Router 3725. Para habilitar OSPF en el Cisco Nexus se realiza desde la configuración de la interfaz.

Topologia en GNS3.

Habilitamos OSPF
N7K-2(config)# feature ospf
Habilitamos el proceso de OSPF
N7K-2(config)# router ospf 10
N7K-2(config-router)# router-id 10.10.10.1
Habilitamos OSPF en la interface en particular
N7K-2(config)# int ethernet 2/2
N7K-2(config-if)# ip address 10.10.10.1 255.255.255.0
N7K-2(config-if)# no shutdown
N7K-2(config-if)# ip router ospf 10 area 0
N7K-2(config-if)# end
N7K-2#
Configuración de OSPF en el Cisco 3725.
ESW1(config)#interface fastEthernet0/1
ESW1(config-if)#ip add 10.10.10.2 255.255.255.0
ESW1(config-if)#no shutdown

ESW1(config)#interface fastEthernet0/0
ESW1(config-if)#ip add 10.4.4.4 255.255.255.0
ESW1(config-if)#no shutdown
ESW1(config-if)#exit

ESW1(config)#interface loopback2
ESW1(config-if)#ip address 10.3.3.3 255.255.255.0
ESW1(config-if)#end

ESW1#show ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            10.4.4.4        YES manual up                    up      
FastEthernet0/1            10.10.10.2      YES manual up                    up      
FastEthernet1/0            unassigned      YES unset  up                    down    
FastEthernet1/14           unassigned      YES unset  up                    down    
FastEthernet1/15           unassigned      YES unset  up                    down    
Vlan1                      unassigned      YES unset  up                    down    
Loopback1                  10.2.2.2        YES manual up                    up      
Loopback2                  10.3.3.3        YES manual up                    up      

ESW1(config)#router ospf 10
ESW1(config-router)#network 10.10.10.0 0.0.0.255 area 0
*Mar  1 00:06:10.307: %OSPF-5-ADJCHG: Process 10, Nbr 10.10.10.1 on FastEthernet0/1 from LOADING to FULL, Loading Done
ESW1(config-router)#networ 10.4.4.0 0.0.0.255 area 0
ESW1(config-router)#

Verificación
ESW1#show ip ospf neighbor 

Neighbor ID     Pri   State           Dead Time   Address         Interface
10.10.10.1        1   FULL/BDR        00:00:33    10.10.10.1      FastEthernet0/1
ESW1


ESW1#show cdp neighbors detail 
-------------------------
Device ID: N7K-2(Nexus-Switch)
Entry address(es): 
  IP address: 10.10.10.1
Platform: Nexus-Switch,  Capabilities: Router Switch IGMP 
Interface: FastEthernet0/1,  Port ID (outgoing port): Ethernet2/2
Holdtime : 165 sec

Version :
Cisco Nexus Operating System (NX-OS) Software, Version 5.1(2)

advertisement version: 2
Duplex: full

ESW1#
Verificación en el Cisco Nexus
N7K-2# show ip route
IP Route Table for VRF "default"
'*' denotes best ucast next-hop
'**' denotes best mcast next-hop
'[x/y]' denotes [preference/metric]

10.4.4.0/24, ubest/mbest: 1/0
    *via 10.10.10.2, Eth2/2, [110/50], 00:00:11, ospf-10, intra
10.10.10.0/24, ubest/mbest: 1/0, attached
    *via 10.10.10.1, Eth2/2, [0/0], 00:01:52, direct
10.10.10.1/32, ubest/mbest: 1/0, attached
    *via 10.10.10.1, Eth2/2, [0/0], 00:01:52, local
N7K-2#

N7K-2# show ip ospf neighbors
 OSPF Process ID 10 VRF default
 Total number of neighbors: 1
 Neighbor ID     Pri State            Up Time  Address         Interface
 10.3.3.3          1 FULL/DR          00:00:09 10.10.10.2      Eth2/2


N7K-2# ping 10.10.10.2
PING 10.10.10.2 (10.10.10.2): 56 data bytes
64 bytes from 10.10.10.2: icmp_seq=0 ttl=254 time=10 ms
64 bytes from 10.10.10.2: icmp_seq=1 ttl=254 time=10 ms
64 bytes from 10.10.10.2: icmp_seq=2 ttl=254 time=10 ms
64 bytes from 10.10.10.2: icmp_seq=3 ttl=254 time=10 ms
64 bytes from 10.10.10.2: icmp_seq=4 ttl=254 time=10 ms

--- 10.10.10.2 ping statistics ---
5 packets transmitted, 5 packets received, 0.00% packet loss
round-trip min/avg/max = 10/10/10 ms
N7K-2#

N7K-2# ping 10.4.4.4
PING 10.4.4.4 (10.4.4.4): 56 data bytes
64 bytes from 10.4.4.4: icmp_seq=0 ttl=254 time=10 ms
64 bytes from 10.4.4.4: icmp_seq=1 ttl=254 time=10 ms
64 bytes from 10.4.4.4: icmp_seq=2 ttl=254 time=0 ms
64 bytes from 10.4.4.4: icmp_seq=3 ttl=254 time=0 ms
64 bytes from 10.4.4.4: icmp_seq=4 ttl=254 time=10 ms

--- 10.4.4.4 ping statistics ---
5 packets transmitted, 5 packets received, 0.00% packet loss
round-trip min/avg/max = 0/6/10 ms
N7K-2#

Configuración de DHCP Server en FortiGate

El FortiGate puede actuar como un servidor DHCP para distribuir dirección IP a los hosts finales que ejecutan servicios de un cliente DHCP. Esta característica es importante si se tiene una pequeña sucursal que no posee un servidor DHCP dedicado.

Para habilitar el servicio de DHCP en el FortiGate se puede realizar desde la interfaz web en las opciones de System > Network > Interface. Para configurar este servicio desde el CLI.

Datos del servidor DHCP.

Interface: port3 (INSIDE)
Rango de direcciones IP: 192.168.23.50 - 192.168.23.100
Subnet: 255.255.255.0
Default Gateway: 192.168.23.1
DNS: Servicio de DNS por default
Nombre de Dominio: delfirosales.com

Configuracion de la interface Inside.
edit "port3"
    set vdom "root"
    set ip 192.168.23.1 255.255.255.0
    set allowaccess ping
    set type physical
    set alias "INSIDE"
    set snmp-index 3
next
Configuracion del DNS.
FortiGate-VM # show system dns 
config system dns
    set primary 8.8.8.8
    set secondary 8.8.4.4
    set domain "delfirosales.com"
    set source-ip 192.168.1.102
end
Configuración de DHCP Server desde CLI
FortiGate-VM # config system dhcp server 
FortiGate-VM (server) # edit 1
new entry '1' added
FortiGate-VM (1) # set auto-configuration disable 
FortiGate-VM (1) # set default-gateway 192.168.23.1
FortiGate-VM (1) # set dns-service default 
FortiGate-VM (1) # set interface port3
FortiGate-VM (1) # config ip-range 
FortiGate-VM (ip-range) # edit 1
new entry '1' added
FortiGate-VM (1) # set start-ip 192.168.23.50
FortiGate-VM (1) # set end-ip 192.168.23.100
FortiGate-VM (1) # next 
FortiGate-VM (ip-range) # end
FortiGate-VM (1) # set netmask 255.255.255.0
FortiGate-VM (1) # next 
FortiGate-VM (server) # end

FortiGate-VM # 
FortiGate-VM # show sys dhcp server 
config system dhcp server
    edit 1
        set auto-configuration disable
        set default-gateway 192.168.23.1
        set dns-service default
        set interface "port3"
            config ip-range
                edit 1
                    set end-ip 192.168.23.100
                    set start-ip 192.168.23.50
                next
            end
        set netmask 255.255.255.0
    next
end
FortiGate-VM # 
Verificacion del Servicio
root@labs:/home/delfi# ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 00:00:AB:5C:A9:00  
          inet addr:192.168.23.50  Bcast:192.168.23.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:179 errors:0 dropped:0 overruns:0 frame:0
          TX packets:158 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:26721 (26.0 KiB)  TX bytes:50476 (49.2 KiB)

root@labs:/home/delfi# 

root@labs:/home/delfi# route -e
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
default         192.168.23.1    0.0.0.0         UG        0 0          0 eth0
127.0.0.1       *               255.255.255.255 UH        0 0          0 lo
192.168.23.0    *               255.255.255.0   U         0 0          0 eth0

root@labs:/home/delfi# ping www.google.com
PING www.google.com (173.194.115.176): 56 data bytes
64 bytes from 173.194.115.176: seq=0 ttl=57 time=134.307 ms
64 bytes from 173.194.115.176: seq=1 ttl=57 time=248.415 ms
64 bytes from 173.194.115.176: seq=2 ttl=57 time=166.495 ms
64 bytes from 173.194.115.176: seq=3 ttl=57 time=50.341 ms
64 bytes from 173.194.115.176: seq=4 ttl=57 time=283.354 ms
64 bytes from 173.194.115.176: seq=5 ttl=57 time=187.280 ms
64 bytes from 173.194.115.176: seq=6 ttl=57 time=69.864 ms
64 bytes from 173.194.115.176: seq=7 ttl=57 time=102.955 ms
64 bytes from 173.194.115.176: seq=8 ttl=57 time=107.317 ms
64 bytes from 173.194.115.176: seq=9 ttl=57 time=84.637 ms
64 bytes from 173.194.115.176: seq=10 ttl=57 time=142.454 ms


Configuración de SVIs en un Switch de Capa 3

Las VLAN dividen dominios de transmisión en un entorno LAN. Siempre que los host de una VLAN necesitan comunicarse con algun otro host en otra VLAN, debe enrutarse el tráfico entre ellos. Esto se denomina ruteo interVLAN. En los switches Catalyst, se logra al crear interfaces de Capa 3 (Switch Virtual Interface - SVI).

Host1
IP: 10.1.1.5
Default Gateway: 10.1.1.1
Subnet: 255.255.255.0 

Host2
IP: 10.1.2.2
Default Gateway: 10.1.2.1
Subnet: 255.255.255.0
Topologia en GNS3 utilizando la imagen vIOS-L2 y Core Linux.

Configuracion en Core Linux 1.
labs login: delfi
Password:
                                   /\_/\
                                  ( o.o )
                                   > ^ <
                              delfirosales.com
delfi@labs:~$ 
delfi@labs:~$ sudo su
root@labs:/home/delfi# ifconfig eth0 10.1.1.5 netmask 255.255.255.0 up
root@labs:/home/delfi# route add default gw 10.1.1.1
Core Linux 2.
delfi@labs:~$ 
delfi@labs:~$ sudo su
root@labs:/home/delfi# ifconfig eth0 10.1.2.2 netmask 255.255.255.0 up
root@labs:/home/delfi# route add default gw 10.1.2.1
root@labs:/home/delfi# 
Habilitar ruteo en el Switch
vIOS-L2#configure terminal
vIOS-L2(config)#ip routing 
Configuracion y creacion de VLANs
vIOS-L2(config)#interface gigabitEthernet0/1
vIOS-L2(config-if)#switchport access vlan 2
% Access VLAN does not exist. Creating vlan 2
vIOS-L2(config-if)#switchport mode access 
vIOS-L2(config-if)#exit

vIOS-L2(config)#interface gigabitEthernet0/2
vIOS-L2(config-if)#switchport access vlan 3
% Access VLAN does not exist. Creating vlan 3
vIOS-L2(config-if)#switchport mode access 
vIOS-L2(config-if)#exit
Verificacion de las VLANs creadas anterior.
vIOS-L2#show vlan   

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Gi0/0, Gi0/3
2    VLAN0002                         active    Gi0/1
3    VLAN0003                         active    Gi0/2
100  VLAN100                          active    
200  VLAN0200                         active    
300  VLAN0300                         active    
1002 fddi-default                     act/unsup 
1003 trcrf-default                    act/unsup 
1004 fddinet-default                  act/unsup 
1005 trbrf-default                    act/unsup 

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0   
2    enet  100002     1500  -      -      -        -    -        0      0   
3    enet  100003     1500  -      -      -        -    -        0      0   
100  enet  100100     1500  -      -      -        -    -        0      0   
200  enet  100200     1500  -      -      -        -    -        0      0   
300  enet  100300     1500  -      -      -        -    -        0      0   
1002 fddi  101002     1500  -      -      -        -    -        0      0   
          
VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1003 trcrf 101003     4472  1005   3276   -        -    srb      0      0   
1004 fdnet 101004     1500  -      -      -        ieee -        0      0   
1005 trbrf 101005     4472  -      -      15       ibm  -        0      0   


VLAN AREHops STEHops Backup CRF
---- ------- ------- ----------
1003 7       7       off

Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------


Creacion de la SVI 2.
vIOS-L2(config)#interface vlan 2
vIOS-L2(config-if)#ip address 10.1.1.1 255.255.255.0
vIOS-L2(config-if)#no shutdown 
vIOS-L2(config-if)#exit
Creacion de la SVI 3.
vIOS-L2(config)#interface vlan 3
vIOS-L2(config-if)#ip address 10.1.2.1 255.255.255.0
vIOS-L2(config-if)#no shutdown 
vIOS-L2(config-if)#end
vIOS-L2#
Si ingresamos el siguiente comando podremos observar que las interfaces se encuentran arriba.
vIOS-L2#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
GigabitEthernet0/0     unassigned      YES unset  up                    up      
GigabitEthernet0/1     unassigned      YES unset  up                    up      
GigabitEthernet0/2     unassigned      YES unset  up                    up      
GigabitEthernet0/3     unassigned      YES unset  up                    up      
Vlan2                  10.1.1.1        YES manual up                    up      
Vlan3                  10.1.2.1        YES manual up                    up      
vIOS-L2#
Tambien podremos observar la tabla de ruteo con el comando show ip route.
vIOS-L2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C        10.1.1.0/24 is directly connected, Vlan2
L        10.1.1.1/32 is directly connected, Vlan2
C        10.1.2.0/24 is directly connected, Vlan3
L        10.1.2.1/32 is directly connected, Vlan3
vIOS-L2#

vIOS-L2#show interfaces vlan 2
Vlan2 is up, line protocol is up 
  Hardware is Ethernet SVI, address is 0000.ab5a.8002 (bia 0000.ab5a.8002)
  Internet address is 10.1.1.1/24
  MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive not supported 
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:10, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     652 packets input, 98538 bytes, 0 no buffer
     Received 0 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles 
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     17 packets output, 1054 bytes, 0 underruns
     0 output errors, 0 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
vIOS-L2#
Verificacion de Core Linux 1 a Core Linux 2.


Otros comandos de verificacion.
vIOS-L2#show interfaces vlan 3
vIOS-L2#show interface gigabitEthernet0/0
vIOS-L2#show interfaces gigabitEthernet0/0 switchport
vIOS-L2#show vlan brief
Descargar Core Linux: LinuxCore-6.4.1.img

Linux Core en Qemu

Imágenes ISO de Linux Core Live x86 o x86-64 se pueden descargar de su pagina la versión mas reciente es el Core 6.4.1.

Creación de la imagen Qemu
$ qemu-img.exe create -f qcow2 LinuxCore.img 300M
Iniciar Qemu con la imagen ISO Live de Core Linux
$ qemu-system-i386w.exe -boot d -cdrom Core-6.4.1.iso -hda LinuxCore.img
Instalacion de Syslinux Extensions
$ tce-load -wi syslinux
Creación de una nueva Particion Ext4
$ sudo fdisk /dev/sda

n - Agregar particion
p - Particion primaria
Partition number (1-4): 1
First cylinder (1-25, default 1): ENTER
Last cylinder (1-25, default 25): ENTER
a - bootable flag
Partition number (1-4): 1
w - guardar la tabla de particion y salir

$ mkfs.ext4 /dev/sda1


Instalar el Boot Sector
$ dd if=/usr/local/share/syslinux/mbr.bin of=/dev/sda
Reconstruir /etc/fstab y Montar la Particion /dev/sda1
$ sudo rebuildfstab
$ mount /mnt/sda1
Montar el CDROM y copiar los archivos core.gz y vmlinuz a /mnt/sda1/boot
$ sudo mkdir -p /mnt/sda1/boot/extlinux
$ mount /mnt/sr0
$ sudo cp -p /mnt/sr0/boot/* /mnt/sda1/boot
Instalar el Boot Loader
$ sudo extlinux --install /mnt/sda1/boot/extlinux
Creación del Archivo extlinux.conf
$ sudo vi /mnt/sda1/boot/extlinux/extlinux.conf

DEFAULT core
LABEL core
KERNEL /boot/vmlinuz
APPEND initrd=/boot/core.gz quiet
Creación de directorios
$ sudo mkdir /mnt/sda1/tce
$ sudo chown tc:staff /mnt/sda1/tce
$ touch /mnt/sda1/tce/mydata.tgz
Apagar Linux Core

Despues de apagar Linux Core ingresar desde consola
$ qemu-system-i386w.exe -boot c -hda LinuxCore.img
Habilitar en Linux Core la redirección al Puerto Serial
default core
label core
kernel /boot/vmlinuz console=ttyS0,38400n8
        append initrd=/boot/core.gz quiet
Extaer el archivo core.gz
$ mkdir -p /home/tc/temp/extract
$ sudo cp /mnt/sda1/boot/core.gz /home/tc/temp/
$ cd /home/tc/temp/extract/

$ zcat ../core.gz | sudo cpio -i -H newc -d
Desabilitar Autologin para tty1 y agregar ttyS0
$ sudo vi /etc/inittab

#tty1::respawn:/sbin/getty -nl /sbin/autologin 38400 tty1
tty1::respawn:/sbin/getty 38400 tty1
ttyS0::respawn:/sbin/getty 38400 ttyS0

Personalizar entrada al sistema
$ sudo vi /etc/issue

Bienvenido a Core Linux

Username "tc", password no establecido
Editar /etc/securetty y permitir acceso al Puerto Serial ttyS0
Descomentar la linea #ttyS0
$ sudo vi ./etc/securetty

ttyS0
Pack File core.gz
$ sudo su
$ cd /home/tc/temp/extract/

$ find | cpio -o -H newc | gzip -2 > /mnt/sda1/boot/core.gz

$ cd /home/tc
$ rm -rf /home/tc/temp

Guardar cambios de configuración de Linux Core

Por default al reiniciar Linux Core no se guardan los cambios realizados, para guardar los cambios que se realicen se debe editar el scrpt /opt/bootlocal.sh el cual se ejecuta en cada inicio de la maquina virtual. El único editor que viene instalado en Linux Core es el editor vi, para editar el script bootlocal.sh ingresar el siguiente comando.
$ sudo vi /opt/bootlocal.sh
Por ejemplo si desea mantener la dirección IP para la interface eth0 con la direccion 10.1.1.1/24 y el nombre de host sea labs, añadir las siguientes líneas a este archivo.
sudo hostname labs
sudo ifconfig eth0 10.1.1.1 netmask 255.255.255.0 up

Ejemplo de guardar cambios en los directorios.
sudo vi /opt/.filetool.lst
/etc/inittab
/etc/issue
/etc/securetty
Una vez guardado los cambios en vi, se tendrá que guardar esta configuración mediante otro script llamado filetool.sh, para guardar cambios ejecutar el siguiente comando:
$ filetool.sh -b
Otros comandos utiles para utilizar.

sudo reboot
sudo poweroff

Apagar Core Linux Qemu y verificar.

$ sudo poweroff

Una vez apagado Core Linux Ingresar el siguiente comando para verificar
$ qemu-system-i386w.exe -boot c -hda LinuxCore.img -serial telnet:0.0.0.0:3000,server,nowait
Una vez iniciado Core Linux ejecutar el siguiente comando desde consola.
$ telnet localhost 3000



NetFlow - Monitorea los equipos de tu red

NetFlow es un protocolo de red desarrollado por Cisco Systems para recolectar información sobre tráfico IP. Netflow se ha convertido en un estándar de la industria para monitorización de tráfico de red, y actualmente está soportado para varias plataformas además de Cisco IOS y NXOS, como por ejemplo en dispositivos de fabricantes como Juniper, Enterasys Switches, y en sistemas operativos como Linux, FreeBSD, NetBSD y OpenBSD.

Existen varias diferencias entre la versión de implementación del Netflow original, por lo que algunas versiones incorporan algunos datos más, pero en líneas generales el Netflow básico envía al menos la siguiente información.
  • Dirección IP de origen.
  • Dirección IP de destino.
  • Puerto UDP o TCP de origen.
  • Puerto UDP o TCP de destino.
  • Protocolo IP.
  • Interfaz (SNMP ifIndex).
  • Tipo de servicio IP.

R1#configure terminal
R1(config)#interface fastethernet0/0
R1(config-if)#ip address 10.10.10.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#end
R1#

Configuración de SNMP y NetFlow
R1(config)#ip access-list standard ACL
R1(config-std-nacl)#permit host 10.10.10.10
R1(config-std-nacl)#exit

R1(config)#hostname RouterLocal

RouterLocal(config)#snmp-server community secreto rw ACL
RouterLocal(config)#snmp-server location Mexico
RouterLocal(config)#snmp-server contact delfirosales

RouterLocal(config)#interface fastEthernet0/0
RouterLocal(config-if)#ip flow egress 
RouterLocal(config-if)#ip flow ingress 
RouterLocal(config-if)#exit

RouterLocal(config)#ip flow-export version 9
RouterLocal(config)#ip flow-export destination 10.10.10.10 99
RouterLocal(config)#ip flow-export source fastEthernet0/0

RouterLocal(config)#service timestamps 
RouterLocal(config)#logging 10.10.10.10
RouterLocal(config)#ip domain name delfirosales.com
Comandos shows
RouterLocal#show ip cache flow
RouterLocal#show ip flow export
RouterLocal#show ip flow interface
RouterLocal#debug ip flow export


Configuración del NetFlow Collector

Hay varios colectores disponibles, algunos licenciados y otros libres, dependiendo de lo que necesites, con cualquier collector te será muy fácil generar el reporte de los top 10 terminales que consumen ancho de banda. Para esta practica se utilizo Real-Time NetFlow Analyzer de SolarisWinds para concentrar la información, analizarla y generar resportes.




Agregar un Adaptador Loopback en GNS3 con Windows 10

Se recomienda no utilizar el asistente de windows (hdwwiz.exe) para crear el adapatador de bluce invertido (loopback) ya que al querer utilizarlo en el GNS3 envia el siguiente error.
Error en GNS3.
GNS3 management console.
Running GNS3 version 1.3.11 on Windows (64-bit) with Python 3.4.2 Qt 4.8.6.
Copyright (c) 2006-2015 GNS3 Technologies.

== > Server error from 127.0.0.1:8000: R1: unable to create generic ethernet NIO

Para solucionar esto debemos utilizar la herramienta llamada Loopback Manager de GNS3, desde el cual podemos eliminar o agregar algun adaptador loopback. En el siguiente video se muestra la solución a este error.


Dynamic PAT en el Cisco ASA

El Cisco ASA soporta los siguientes tipos mas comunes de NAT.
  • Dynamic NAT: Traducción de muchos a muchos. Traduce las direcciones de origen en las interfaces de seguridad más altos en un rango de direcciones o pool a una interface menos segura para las conexiones salientes.
  • Dynamic PAT: Traducción de muchos a uno. Usualmente un pool de direcciones internas a una interface externa.
  • Static NAT: Traducción de uno a uno, entre una dirección IP en una interface más segura y otra interface menos segura (ejemplo internet) para así poder acceder a los host de una interface de mayor seguridad (ejemplo servidores web en la DMZ) sin exponer la dirección IP real del host en la interface de mayor seguridad.
  • Twice NAT: Permite definir origen y destino desde una sola regla. Son procesadas de acuerdo a la secuencia que fueron insertadas (sin diferenciar estáticos de dinámicos). Puede Referenciar objetos de tipo “network” y “service”.
Configuración Básica de NAT - ASA versión 8.4

Practica en GNS3
Topologia de red Dynamic PAT.

Lo primero es configurar las tres interfaces en el ASA. El segmento de la red ISP está conectada a la interface gigabitEthernet3 con la etiqueta de outside y nivel de seguridad 0. La red interna está conectada a la interface gigabitEthernet1 con etiqueta de nombre inside y con nivel de seguridad 100. El segmento DMZ, donde reside el WebServer está conectado a la interface gigabitEthernet2 del ASA y etiquetado con el nombre de dmz con nivel de seguridad 50.

Datos adicionales:

Interface inside: 192.168.0.1 y es default gateway para los host internos.
Interface dmz: 192.168.1.1 y es el default gateway para los host internos.
Interface outside: 198.51.100.100
Ruta de default: Next-Hop 198.50.100.101

Configuración de la Topología de Red

Configuración PC
Configuración WebServer
!
interface FastEthernet0/0
 ip address 192.168.1.100 255.255.255.0
!         
ip route 0.0.0.0 0.0.0.0 192.168.1.1
!

Configuración ISP
!
interface FastEthernet0/0
 ip address 198.51.100.101 255.255.255.0
 duplex auto
 speed auto
!
interface Serial1/1
 ip address 100.1.1.2 255.255.255.252
 serial restart-delay 0
!
ip route 50.50.50.0 255.255.255.0 100.1.1.1
ip route 89.89.89.0 255.255.255.248 198.51.100.100
ip route 192.168.0.0 255.255.255.0 198.51.100.100
!
Configuración R4
!
interface FastEthernet0/0
 ip address 50.50.50.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial1/1
 ip address 100.1.1.1 255.255.255.252
 serial restart-delay 0
!
ip route 89.89.89.0 255.255.255.248 Serial1/1
ip route 198.51.100.0 255.255.255.0 Serial1/1
!
Configuración R5
!
interface FastEthernet0/0
 ip address 50.50.50.17 255.255.255.0
 duplex auto
 speed auto
!         
ip route 0.0.0.0 0.0.0.0 50.50.50.1
!
line vty 0 5
 password cisco
 login
!
Configuración del ASA
!
interface GigabitEthernet1
 nameif inside
 security-level 100
 ip address 192.168.0.1 255.255.255.0 
!
interface GigabitEthernet2
 nameif dmz
 security-level 50
 ip address 192.168.1.1 255.255.255.0 
!
interface GigabitEthernet3
 nameif outside
 security-level 0
 ip address 198.51.100.100 255.255.255.0 
!
route outside 0.0.0.0 0.0.0.0 198.51.100.101 1
!

Configuración de Dynamic PAT en el ASA
CiscoASA# configure terminal
CiscoASA(config)# object network red-interna
CiscoASA(config-network-object)# subnet 192.168.0.0 255.255.255.0
CiscoASA(config-network-object)# nat (inside,outside) dynamic interface
CiscoASA(config-network-object)# exit

CiscoASA(config)# object network red-dmz
CiscoASA(config-network-object)# subnet 192.168.1.0 255.255.255.0
CiscoASA(config-network-object)# nat (dmz,outside) dynamic interface
CiscoASA(config-network-object)# end
CiscoASA#

Verificación.
Para verificar que está funcionando, volvemos a intentar realizando un telnet a la ip 50.50.50.17.



Habilitando el debug ip icmp para verificar el comportamiento y algunos comandos shows.
R5#debug ip icmp

CiscoASA# show xlate


CiscoASA# show nat detail
CiscoASA# show nat translated interface outside
CiscoASA# sh  local-host

Como crear un LiveUSB de Wifislax 4.11.1

WifiSlax es una distro GNU/Linux que se ejecuta en modo Live, es decir; no se instala físicamente en el disco duro, sino que se bootea desde un CD/DVD. Está pensada y diseñada para la auditoria de seguridad y relacionada con la seguridad informática en general e incluye una gran variedad de herramientas listas para ser utilizar. Hoy vamos a ver cómo crear un LiveUSB a partir de la imagen ISO.

Herramientas a Utilizar.
  • Imagen ISO de Wifislax.
  • Memoria USB de al menos 2 Gigas.
El primero paso que tenemos que hacer es descargar la ISO de WifiSlax desde su página oficial.

Nombre archivo: wifislax-4-11-1-final.iso 1.09 GB
Hash MD5: dd00c7cca12ab7bb7de76aeb73fd2565

Opciones de descarga:
El paso siguiente es preparar la memoria USB que vamos a utilizar, debemos de formatear con formato FAT32. Una vez descargado el Wifislax descomprimir el archivo de imagen ISO con algún descompresor (ejemplo Winrar) o el que utilicen habitualmente. Al terminar de descomprimir creara dos carpetas, una llamada Boot y la otra Wifislax. El siguiente paso será copiar estas dos carpetas a la memoria USB.

Una vez copiados las dos carpetas en la memoria usb, iremos a la carpeta Boot de la memoria usb y ejecutaremos el archivo llamado Wifislax Boot Installer.
 Wifislax Boot Installer.

Ejecutado el archivo nos aparecerá un mensaje de consola que nos pedirá la confirmación, ingresamos la tecla "s" para confirmar.


Con esto ya podremos arrancar Wifislax desde el USB. Por si tienen activado la UEFI es necesario desactivarlo desde la Bios para poder iniciar desde la USB y también deben asegurarse iniciar desde la USB como primera opción de arranque.


 Al iniciar con el LiveUSB nos aparecerá un menú donde podremos elegir varios modos de arranque, si tenemos menos de 4 GB de RAM seleccionamos “Arrancar con kernel NORMAL” y si cuenta con más memoria de la mencionada sería la opción de “Arrancar con kernel PAE”.

A continuación, podemos elegir entre KDE y Xfce como entorno gráfico.

Esperamos un poco y listo ya podremos utilizar el Wifislax desde la memoria USB.


Usuario: root
Pass: toor

Configuración de NTP con Autenticacion en un Router Cisco

NTP son las siglas de Network Time Protocol el cual nos permite sincronizar los dispositivos que funcionan en una red. Esto es muy importante ya que hay una gran variedad de servicios de red que se basan en la correcta sincronización de horarios de los servidores.

Para esto, el equipo realiza una referencia a un servidor de horario, que puede comparar y ajustar su fecha y la hora con otro servidor NTP publico en internet. El protocolo NTP utiliza el puerto UDP 123 para establecer la conexión con los servidores de horario. Es recomendable e importante configurar primero el protocolo NTP en los equipos de la nuestra red antes de implementar el protocolo estándar Syslog centralizado.

NTP en GNS3.

Configuración de un router Cisco para que sincronice la fecha y hora con un servidor de NTP público en internet.

Primero verificamos conectividad con el servidor NTP público en internet.
R1#ping pool.ntp.org
Translating "pool.ntp.org"...domain server (192.168.137.1) [OK]
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 132.248.30.3, timeout is 2 seconds:
!!!.!
Success rate is 80 percent (4/5), round-trip min/avg/max = 76/98/120 ms
R1#

Verificando conexión.
Configuración del Cliente NTP en R1.
R1#configure terminal
R1(config)#ntp server pool.ntp.org
Translating "pool.ntp.org"...domain server (192.168.137.1) [OK]
R1(config)#

Verificación.
R1#show clock detail
07:17:15.480 UTC Sun Mar 29 2015
Time source is NTP
 
R1#show ntp status
R1#show ntp associations


Verificación de NTP y comandos adicionales del estado de NTP.

Configuración en R2.
R2#configure terminal
R2(config)#ntp server 10.10.10.1
R2(config)#end
R2#
*Mar  1 00:14:15.523: %SYS-5-CONFIG_I: Configured from console by console
 
R2#show clock detail
.07:22:29.536 UTC Sun Mar 29 2015
Time source is NTP
R2#

NTP con Autenticación
R1#configure terminal
R1(config)#ntp authentication-key 1 md5 cisco
R1(config)#ntp authenticate
R1(config)#ntp trusted-key 1

Configuración de R2 como cliente NTP con autenticación.
R2#configure terminal
R2(config)#ntp authenticate
R2(config)#ntp authentication-key 1 md5 cisco
R2(config)#ntp trusted-key 1
R2(config)#ntp server 10.10.10.1 key 1

Syslog Server: Kiwi Syslog - Configuracion de un router Cisco

Si queremos enviar los mensajes de log a un servidor de Syslog (Syslog server) para poder administrar los logs del dispositivo de la red de una forma mas centralizada, podemos enviar los logs que se generan y para que los mensajes se envíen a un servidor.

Es importante que antes de implementar el almacenamiento del log en un Syslog Server, todos los dispositivos de la red estén sincronizados con la misma hora, día y fecha. Para esto debemos de configurar el protocolo Network Time Protocol (NTP) en los switches y routers. Si no sabes realizar esta configuración podras consultar la siguiente publicación sobre NTP Server.

Syslog Server en GNS3.

Para configurar a que el router envíe los logs al Syslog Server debemos ingresar el siguiente comando, loggin host ip_servidor o el comando loggin ip_servidor, indicando la dirección IP del Servidor de Syslog.

Router(config)#logging host 10.10.20.10

10.10.20.10 es el servidor de log.

Podemos limitar la cantidad de mensajes enviados al servidor syslog, según la gravedad con el comando logging trap para establecer el nivel de detalle de la información que será registrada en el log. En este caso es de nivel 7 (debugging) que es el nivel más alto. Niveles de mensajes de Syslog.

R1(config)# logging trap 7

Otro comando importante es el service timestamps, esta configuración es muy importante cuando estemos configurando el loggin porque con esto vamos habilitar que aparezcan los logs con la fecha y la hora en que se genera el log, por default no está habilitado y básicamente lo que hace es que si te pone el log pero no te dice a qué hora fue generado el log, entonces este comando es importante configurarlo en el router.

Router(config)#service timestamps

La segunda parte del procedimiento es efectivamente instalar un software servidor de Syslog en una PC Windows o Linux. Kiwi Syslog Server para Windows es una excelente opción, fácil de instalar y configurar.

Verificacion

R1#debug ip icmp 
ICMP packet debugging is on
R1#

R1#ping 10.10.20.10
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.20.10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/50/148 ms
R1#

00:09:28: ICMP: echo reply rcvd, src 10.10.20.10, dst 10.10.20.1
00:09:28: ICMP: echo reply rcvd, src 10.10.20.10, dst 10.10.20.1
00:09:28: ICMP: echo reply rcvd, src 10.10.20.10, dst 10.10.20.1
00:09:28: ICMP: echo reply rcvd, src 10.10.20.10, dst 10.10.20.1
00:09:28: ICMP: echo reply rcvd, src 10.10.20.10, dst 10.10.20.1

R1#conf t
R1(config)#exit
R1#
*Mar  1 00:09:35.999: %SYS-5-CONFIG_I: Configured from console by console
R1#


Kiwi Syslog en Windows.

Así de simple podemos centralizar la administración del log en nuestra red y mejorar significativamente la respuesta a un posible incidente o ataque de seguridad que tengamos que enfrentar.

Syslog

El Syslog es enviar mensajes de información que puede ser a un router o a un servidor externo.

¿Para que nos va servir el Syslog?

El Syslog nos puede servir para sabes cual es la naturaleza de alguna ataque o amenaza de seguridad. También nos sirve de bastante para Troubleshooting y podemos correlacionar cualquier tipo de eventos, como por ejemplo.
  • Un intento de acceso con contraseña equivocada
  • Un acceso correcto al sistema
  • Anomalías: variaciones en el funcionamiento normal del sistema
  • Alertas cuando ocurre alguna condición especial
  • Información sobre las actividades del sistema operativo
  • Errores del hardware o el software
Por lo tanto, es vital la administración adecuada de esta información para mantener corriendo de manera estable una red y principalmente para poder mitigar las amenazas de seguridad a las que nos podamos ver expuestos.

Los logs también se pueden enviar a la consola (por default)
  • Al Logging Buffer del Router (por default)
  • A las Líneas VTY (Ingresando el comando terminal monitor)
  • A un Servidor de SNMP como puede ser un Cisco Works
  • A un servidor de Syslog.
Existe un Cliente y Servidor de Syslog.
  • El Syslog Client es el que envía los logs, es decir un router puede ser un cliente de Syslog.
  • Servidor Syslog es un aquel servidor que guarda todos los logs.
Syslog Levels.

La figura anterior muestra los niveles de Syslog que se tienen.
  • Nivel 0 son las Emergencias: Es cuando hay un error severo que hace que el sistema no sea usable
  • Nivel 1 son Alertas: Significa que requieren atención inmediata.
  • Nivel 2 Critica: Requiere atención para prevenir que haya interrupción en el servicio.
  • Nivel 3 Errores: Condiciones de errores en el Sistema.
  • Nivel 4 Warnings: Es cuando algo en específico falla.
  • Nivel 5 Notificaciones: Alerta sobre los cambios de estados.
  • Nivel 6 Información: Información detallada acerca de la operación normal.
  • Nivel 7 Debugging: Información detallada, comandos de debug, usualmente puede servir simplemente para troubleshooting.
Es importante saber que existen estos 8 niveles, que significa cada uno y como se llaman.

Iniciando un router se presentan varios log, ejemplo.
Press RETURN to get started!
*Mar  1 00:00:07.059: %LINEPROTO-5-UPDOWN: Line protocol on Interface VoIP-Null0, changed state to up
5 = Nivel 5
*Mar  1 00:00:07.059: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Mar  1 00:00:07.063: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
3 = Nivel 3
*Mar  1 00:00:07.287: %SYS-5-CONFIG_I: Configured from memory by console
*Mar  1 00:00:07.875: %SYS-5-RESTART: System restarted --
Cisco IOS Software, 3600 Software (C3660-IK9O3S-M), Version 12.4(13b), RELEASE SOFTWARE (fc3)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Tue 24-Apr-07 21:18 by prod_rel_team
*Mar  1 00:00:07.887: %SNMP-5-COLDSTART: SNMP agent on host Router is undergoing a cold start
*Mar  1 00:00:08.059: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to down
*Mar  1 00:00:09.299: %LINK-5-CHANGED: Interface FastEthernet0/1, changed state to administratively down

En el IOS de Cisco por default está configurado el log en la consola.